Понедельник, 11.12.2017, 03:21
Сайт для администрации школы
Главная Регистрация Вход
Приветствую Вас, Гость · RSS
Меню сайта
Посильная помощь
Софт в помощь
Наш опрос
О статусе автономного учреждения
Всего ответов: 475
 Каталог статей
Главная » Информационные технологии

Логические формулы в Excel. Формула проверки условия "ЕСЛИ".

Вы, конечно, в курсе, что Excel состоит из столбцов и строк. Ячейка - это пересечение столбца и строки. Таким образом, каждая ячейка имеет своё имя. Например С1 или В10. В ячейку можно вносить текст, числа и все это будет в ней отображаться. Но в ячейку можно вносить и формулы, которые что-то подсчитывают.

Давайте разберемся. В Excel есть строка формул. Вот она на рисунке, там еще буковки fx. Так вот, ячейку можно заполнить внося данные непосредственно в нее саму, а можно вносить в строку формул, предварительно выделив ячейку. Вновь посмотрите на рисунок. В ячейке С1 слово "привет", оно же и в строке формул.






А теперь смотрите в ячейке С1 стоит "4". А в строке формул что? Правильно, формула =2+2. Получается, что ячейка С1 "прочитала" формулу для нее предназначенную, "посчитала" и показала нам результат.

Но это арифметическая формула. А нам-то нужно логическую. Пусть эта ячейка(С1) проверит, что стоит в ячейке В1 и в зависимости
от того, что там находится что-нибудь нам "скажет".

Давайте проверять оценки (учителя мы или где?). Если в В1 "5" пусть пишет "отлично", а если не "5"... Итак, выделяем ячейку С1 и пишем в строке формул (но можно и в самой ячейке) следующее: =ЕСЛИ(В1=5;"отлично";"что сказать?"). Теперь внесем в ячейку В1 число 5. Что появилось в С1? Слово "отлично".

Как это работает? Любая формула (в т.ч. и логическая) начинается со знака [=](равно). Мы так и написали. Затем идет слово ЕСЛИ (большими буквами). Т.е. ячейка получает предупреждение: "сейчас будем что-то проверять". Открываются скобки. И сразу пишем, что проверяем. А проверяем мы ячейку В1 на предмет ее равенства 5 [В1=5]. Ну проверили и что дальше? А дальше знак [;](точка с запятой) и пишем что делать, если проверка условия прошла успешно и условие оказалось верным - ["отлично"]. Опять знак [;] и пишем что делать, если проверка условия прошла, но условие не соответсвует заданному - ["что сказать?"]. Обратите внимание на кавычки , обрамляющих слова. Они необходимы, чтобы Excel "понял", что надо выводить текст. Все, скобки закрываем, формула готова. И она работает.  Просто, не правда ли?   

Давайте я еще раз напишу эту логическую формулу, выделив цветом ее части: =ЕСЛИ(В1=5;"отлично";"что сказать?"). Здесь жирным шрифтом выделено условие, которое проверяет Excel, жирным зеленым шрифтом то, что должно быть написано, если условие верно. Ну, а красным жирным шрифтом - то, что надо писать, если условие неверно.

А теперь давайте слегка усложним задачу. Пусть С1 показывает нам слово "хорошо", если в ячейке В1 стоит 4. Помните, что означает "что сказать?" в нашей формуле? Это то, что должна нам написать ячейка С1, если в В1 стоит не 5. Так вот давайте вместо этого "что сказать?" напишем формулу: ЕСЛИ(В1=4;"хорошо";"ну не знаю"). 

Получилось вот что в ячейке С1: =ЕСЛИ(В1=5;"отлично";ЕСЛИ(В1=4;"хорошо";"ну не знаю")).

Как читает это Excel? Если в ячейке В1 стоит 5, то отобразить слово "отлично", иначе если в ячейке В1 стоит 4 - отобразить слово "хорошо". А уж если в ячейке стоит что-то другое - отобразить слова "ну не знаю".

Так Excel и поступает. На рисунке я в ячейку В1 внес 3. Excel проверил все условия, ему заданные и написал "ну не знаю".

Продолжим наше дело дальше. Пусть Excel проверяет и 3, и 2, внесенные в В1. И пусть сообщает что это "удовлетворительно" и "плохо" соответственно. А если будет в В1 что-то другое напишет "таких оценок не бывает".

Что делаем? Ищем в нашей формуле блок, где Excel получил команду что отображать, если в В1 не 4 и не 5. Это у нас "ну не знаю". Вместо него пишем условие на проверку В1 насчет 3. Там, где надо Excel давать команду, что делать, если в В1 не 3 - пишем условие на проверку В1 насчет 2. И там уж в конце дадим команду Excel что писать, если в В1 что-то другое.
Вот смотрите что получилсь.

=ЕСЛИ(B1=5;"олично";ЕСЛИ(B1=4;"хорошо";ЕСЛИ(B1=3;"удовлетворительно";ЕСЛИ(B1=2;"плохо";"таких оценок не бывает")))) 

Такое написание называют вложенными условиями. Эти условия можно вкладывать много раз. Главное быть внимательным и не запутаться самому. Особенно со скобками.

Вроде все. Скопируем нашу формулу в ячейки, начиная с С2 и до ... (сколько нужно). Вносим в ячейки столбца В разные значения
и смотрим, что нам пишет Excel. У меня вот что получилось. 

А теперь я решил сделать так, чтобы при оценке 2 в ячейке столбца В слово "плохо" было бы написано на траурном черном фоне жирным белым шрифтом. Вот так:

Как это сделать? Выделяем ячейку. Идем в пункт меню "Формат", выбираем "Условное форматирование" и вносим там необходимые
нам условия. Попытайтесь это сделать самостоятельно.

Есть и другие способы проверки условий. При помощи слов "И" и "ИЛИ". Напишу об этом в следующий раз.


Публикации схожей тематики:



Категория: Информационные технологии | Добавил: Last (12.07.2009)
Просмотров: 154144 | Комментарии: 67 Теги | Рейтинг: 4.6/24 |
Всего комментариев: 671 2 3 4 5 »
67  
Добрый день!

Помогите, пжл, очень надо.

Есть число А, и есть число В. Нужно автоматизировать через формулу:

если А меньше или равно 90% от В, то А умножить на 0%; Если А больше 90% от В, но меньше или равно 115% от В, то умножить на 0,1; Если А больше 115% от В, то умножить на 0,2%

Это все должно быть в одной формуле - уже час мучаюсь((((((

66  
Подскажите пожалуйста! Мне надо сделать так, чтобы в формуле "ЕСЛИ", в том случае, если хотя бы в одной из перечисленных ячеек была правда-то писалось "правда", ато пишет #ЗНАЧ!
К примеру: =ЕСЛИ(A2:AZ2000="67301 16";["ИСТИНА"];["ЛОЖЬ"] ) в этом случае у меня пишет "ЛОЖЬ", хотя в одной из перечисленных ячеек есть данное число. А если выбрать только ячейку в которой это написано, то все нормально. А мне надо, чтобы искал во всех ячейках, и если находит хоть в одной, то писал "ИСТИНА".

65  
Помогите с задачей:
Оценка рассчитывается исходя из условия: если Полная сумма капвложений (Кп) меньше или равны 50 000, то оценка 3, если Кп больше 50 000 и меньше 60 000, то оценка 4, а если Кп больше или равна 60 000, то оценка 5.

Вот получалась формула у меня =ЕСЛИ(F11<=50000;"3";ЕСЛИ(F11>=60000;"5";ЕСЛИ(F11>50000;F11<60000;"4")))

но не считает четверки почему то.

64  
Помогите мне, пожалуйста. Неделю пытаюсь освоить логические формулы. Забиваю формулу в точности, как у вас, на пишет в ячейке #ИМЯ? Что делать -

63  
помогите пожалуйста записать правильно логическую функцию ЕСЛИ (если вклад «срочный», то 20%, если «обычный», то 3%, если «пенсионный», то 15%).

62  
Здрасти. Помогите сделать формулу. если А1=1 то В2=51 если А1=2 то В2=52 если А1=3 то В2=53...........если А1=41 то В2=91

61  
Здрасти. Помогите сделать формулу.

60  
Леонид, пожалуйста, помогите, мне в мои 55 лет сложно разобраться, а очень нужно:
если в ячейке значение меньше 180,00000, то нужно прибавить 180, а если больше 180,00000, то нужно отнять 180. То есть результат не должен превышать 360,00000.
Пожалуйста, не отсылайте к ранним комментариям. Заранее спасибо!

59  
=ЕСЛИ(И(D3<2000;C3+(E3-G3)/10);И(D3>8000;C3+E3-G3);И(D3>=16000;(C3+E3-G3)
Что может быть неправильное в формуле?

58  
Здравствуйте. Помогите пожалуйста. Не совсем понимаю что не правильно в формуле. Когда считаю руками - одна цифра, когда считает программа - другая цифра.

=ЕСЛИ(ЕОШИБКА(ОКРУГЛ((1+(1,31*L19+0,95*M19)/U19)*T45;3));0;ОКРУГЛ((1+(1,31*L19+0,95*M19)/U19)*T45;3))

Фу = 1,0+(1,31 х Кау + 0,95 х Кду) / Кобщ х У

Кау соответствует L19
Кду соответствует M19
Кобщ соответствует U19
У соответствует T45

1-10 11-20 21-30 31-40 41-46
Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]
Copyright Last © 2017
Google рекламирует
Форма входа

Законы Мерфи
Зубная боль обычно начинается в ночь на субботу.
Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0
Друзья сайта
  • ЕГЭ: обществознание, история.
  • Википедия
  • Сайт управляется системой uCoz